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Copyright
l Copyrights for music andMIDI are located with their respectivemusic andMIDI files..
l All other assets are the Copyright of Little Dreamer Games. All rights reserved.
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Overview

SUMMARY
Sound Reactor is a Unity Extension that makes it easier than ever to make things in Unity react to sound. And
now with the Pro version, you can alsomake things in Unity react toMIDI events that can be played back from
midi files. It is a versatile Unity Extension that is bothmodular and flexible. With it, you can create stunning visu-
alizers, and drive any property to anyUnity AudioSource orMidiSourcewith ease.

Features
Some features are only available in Sound Reactor Pro.

Standard
l Easy to use and powerful Spectrum Builder
l Property drivers that drive: color, position, rotation, scale, particle emitters, and physics forces
l Event handler driver that can be used to drive any public property
l Expandable property driver class so you can create your own property drivers
l Remembers changes made during play mode
l A modular design that makes it possible to integrate into any project

Pro
l Drive property values with MIDI note velocities.
l HandleMIDI events directly with a customMIDI Event Handler. SeeMIDI for all the events andmessages Sound
Reactor Pro supports.

BASICS
The setup for Sound Reactor is fairly basic. A typical setup consists of some foundation scripts, some drivers to
drive properties, andGameObjects that contain said scripts.

Foundation Scripts
These scripts are necessary for any project using Sound Reactor. They are:
l SpectrumSource
l SpectrumFilter
l Level
l One ormore drivers that inherit from PropertyDriver

Peaks
A peaks are used to normalize audio frequencies. Readmore about what that means here:PeaksProfile. Peaks
profiles that are included with Sound Reactor are fine for general purposes use.

Drivers
Drivers are what cause property values to change. The drivers included with Sound Reactor are:
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Standard
l PositionDriver
l RotationDriver
l ScaleDriver
l ColorDriver
l ForceDriver
l ParticleEmitterDriver
l EventDriver

Pro
l MidiTrackColorDriver

Supplemental

l EQ
l Spectrum Builder

MODULAR DESIGN
Sound Reactor is designed in such a way that connections between certain scripts can be donemanually, or set
up in a hierarchy so connections happen automatically. The hierarchy example in the figure below is set up so
connections happen automatically.

Automatic Connections
The following scripts are arranged in the order they look for each other at runtime. i.e. PropertyDriver looks for
Level, Level looks for SpectrumFilter, and so on. It does this by first looking for the script on theGameObject
it's attached to, and if it doesn't find one, it travels up through each parent GameObject until it findswhat it's look-
ing for.
l PropertyDriver
l Level
l SpectrumFilter
l SpectrumSource
l AudioSource
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HIERARCHY EXAMPLE
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Basic Setup

SUMMARY
This is themost basic setup using:SpectrumSource, SpectrumFilter, Spectrum Builder, andScaleDriver

Demos
See theBasicSetup scene in Demos included with Sound Reactor.

Setup

Setting up the hierarchy
1. In the hierarchy view, click: Create->Audio->Audio Source
2. Add an audio clip to the Audio Source. If you don’t have one, you can search for the “Don't Make Me” song.
3. Right click in an empty place in the Hierarchy and select: SoundReactor->SpectrumSource
4. Drag Audio Source into the Audio Source property in SpectrumSource (leaving this property empty will cause all the
sounds together to become one spectrum)
5. Right click the new SpectrumSourceGameObject and select: SoundReactor->SpectrumFilter
6. Right click the new SpectrumFilterGameObject and select: SoundReactor->Builder

Staging a Level for the Builder
7. Create a GameObject called Staging at the root of the hierarchy
8. Right clickStaging and select: SoundReactor->Level
9. Right click Level and select: 3D Object->Cube
10. Click on theCube and select: Tools->SoundReactor->Driver->Scale
11. Set the Y in Travel to 8
12. Disable the StagingGameObject since it’s not used beyond using it to build up the spectrum.

Building the spectrum visualizer
13. Click on the SpectrumBuilder
14. Click and drag the Level into the Level property in the SpectrumBuilder

Preview
15. Go into playmode and the cubes should be scaling with the audio.
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RESULT
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MIDI Setup

SUMMARY
Builds a custom piano that reacts to MIDI events.

This feature is only available in Sound Reactor Pro.

Demos
See theMidiSetup scene in Demos included with Sound Reactor Pro.

Setup

Add AudioMidiSync
1. Right click in an empty place in the Hierarchy and select: SoundReactor->AudioMidiSync.
2. With AudioiMidiSync still selected, add both an AudioSource and aMidiSource component.
3. Locate the K545 audio and MIDI file and attach them to the AudioSource andMidiSource Source properties.

Add SpectrumSource
4. Right click in an empty place in the Hierarchy and select: SoundReactor->SpectrumSource
5. Click on SpectrumSource then select: Tools->SoundReactor->Component->SpectrumFilter
6. Change theMode toMidi
7. Drag AudioMidiSync into the Source property

Add PianoKeys
8. Create a newGameObject called Staging at the root and disable it.
9. Create a new child GameObject under Staging called PianoKeys.
10. Locate the PianoKeys asset folder. Drag all the piano keys into the PianoKeys GameObject.
11. Select all the piano keys under the PianoKeys GameObject and add aMidiTrackColorDriver and aRotationDriver script
to them.
12. Select keys: AS, CS, DS, FS and GS, and set their resting color to black.
13. Set the Travel for theRotationDriver to: (-3.5, 0, 0), and the Strength to 2

Add SpectrumBuilder
14. Right click on the SpectrumSource and select: SoundReactor->Builder.
15. Select the SpectrumBuilder and set it's mode to Piano.
16. Drag the PianoKeys GameObject that was created at step 9 into the SpectrumBuilder'sPianoKeys property.
17. Set the Frequency Range->Mode toMidi
18. Set the Frequency Range->Preset to 88 Keys (C)
19. Set Layout->Levels to 88 to match the preset.
20. Set the Level->Start Note to the note indicated by Frequency->Preset, which isC in this case.
21. ClickAssign.
22. ClickBuild.

Preview
23. Go into playmode and the keys should animate and change color to the MIDI.
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RESULT
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Event Driver Setup

SUMMARY
Setup a scene that drives properties.

Demos
SeeEventDriverSetup scene in Demos included with Sound Reactor.

Setup

Event Handler

using UnityEngine;
using LDG.SoundReactor;

public class EmissionHandler : MonoBehaviour
{

public Color emissionColor;

private Material material;
private int emissionColorID;

private void Start()
{

MeshRenderer meshRenderer;

if ((meshRenderer = GetComponent<MeshRenderer>()))
{

if ((material = meshRenderer.material) != null)
{

emissionColorID = Shader.PropertyToID("_EmissionColor");
}

}
}

public void OnLevel(PropertyDriver driver)
{

if (material)
{

float level = driver.LevelScalar();

material.SetColor(emissionColorID, emissionColor * level);
}

}
}

Create the class
1. Create the above EventHandler class and call it EmissionHandler

Basic Setup
2. Follow theBasic Setup.

Attaching the Handler
3. Attach the EmissionHandler class to theCube.
4. Create a newOnLevel handler by pressing the '+' button.
5. Attach theCube to the GameObject property.
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6. Select EmissionHandler->OnLevel from the function drop down menu. Make sure to choose the function located at the top
of the list, which is the dynamic version.

RESULT
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MIDI Event Handler

SUMMARY
Code snippet to handleMIDI eventsmanually.

This feature is only available in Sound Reactor Pro.

Demos
See theMidiEventInfo scene in Demos included with Sound Reactor Pro

Setup

MIDI Event Handler

public void OnMidiEvent(Sequencer sequencer, MidiEvent e)
{

if (!this.enabled || !gameObject.activeSelf) return;

this.sequencer = sequencer;

switch(sequencer.PlayState)
{

case MidiPlayState.End:
// reached the end of the MidiClip
break;

case MidiPlayState.Play:
// the Play function has been called
break;

case MidiPlayState.Stop:
// the Stop function has been called
break;

}

// all possible channel voice messages
if (e.IsChannelVoiceMessage)
{

switch(e.ChannelVoiceMessage)
{

case ChannelVoiceMessage.NoteOff:
// handle message
break;

case ChannelVoiceMessage.NoteOn:
// handle message
break;

case ChannelVoiceMessage.PolyphonicPressure:
// handle message
break;

case ChannelVoiceMessage.ControlChange:
// handle message
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break;
case ChannelVoiceMessage.ProgramChange:

// handle message
break;

case ChannelVoiceMessage.ChannelPressure:
// handle message
break;

case ChannelVoiceMessage.PitchWheelChange:
// handle message
break;

}
}

// all possible meta messages
if (e.IsMetaMessage)
{

switch (e.MetaMessage.MetaType)
{

case MetaType.Text:
// handle message
//Debug.Log("text: " + e.MetaMessage.Text);
break;

case MetaType.CopyrightNotice:
// handle message
//Debug.Log("copyright notice: " + e.MetaMessage.CopyrightNotice);
break;

case MetaType.TrackName:
// handle message
//Debug.Log("track name: " + e.MetaMessage.TrackName);
break;

case MetaType.InstrumentName:
// handle message
//Debug.Log("instrument name: " + e.MetaMessage.InstrumentName);
break;

case MetaType.Lyrics:
// handle message
//Debug.Log("lyrics: " + e.MetaMessage.Lyrics);
break;

case MetaType.Marker:
// handle message
//Debug.Log("marker: " + e.MetaMessage.Marker);
break;

case MetaType.CuePoint:
// handle message
//Debug.Log("cue point: " + e.MetaMessage.CuePoint);
break;

case MetaType.ChannelPrefix:
// handle message
//Debug.Log("channel prefix: " + e.MetaMessage.ChannelPrefix);
break;

case MetaType.EndOfTrack:
// handle message
//Debug.Log("end of track");
break;

case MetaType.Tempo:
// handle message
//Debug.Log("tempo: " + e.MetaMessage.Tempo);
break;

case MetaType.SMPTEOffset: // handled, but not supported
// handle message
/*
Debug.Log
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case MetaType.SequenceNumber:
// handle message
//Debug.Log("sequence number: " + e.MetaMessage.SeqeunceNumber);
break;

}
}

}

Basic Setup
1. Follow theMidiSetup.

Attaching the handler
2. Create or open a MonoBehaviour script and paste in the above method.
3. Select the GameObject that has aMidiSource component attached to it.
4. Press the '+' button to add a OnMidiEvent handler.
5. Drag the GameObject that has your OnMidiEvent into the Object property.
6. Select OnMidiEvent from the method drop down list.

RESULT
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MIDI File Setup

SUMMARY
Before aMIDI file can be attached to aMidiSource it must be converted to a .asset file first.

This feature is only available in Sound Reactor Pro.

Create a MIDI .asset file
Any of the followingmethodswill create a .asset file from a valid MIDI file. See theMIDI specifications for which
MIDI files are valid.
l Right click on aMIDI file and select: Create->SoundReactor->Midi Clip in theProject tab.
l Click on aMIDI file and select: Create->Assets->SoundReactor->Midi Clip in theProject tab.
l Click on aMIDI file and select:Tools->SoundReactor->Midi Clip in the tool bar.

RESULT
The result will be a new file with the extension .midi.asset, where .midiwill show in the inspector, and .assetwill
be hidden from the inspector.
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MIDI Load Resource

SUMMARY
Reads aMIDI .asset file that's inside aResources folder and attaches it to aMidiSource at runtime. It also loads
anAudioClip and attaches it to an AudioSource.

SeeMIDI File Setup for creating aMIDI .asset file.

This feature is only available in Sound Reactor Pro.

MIDI LOAD RESOURCE CLASS

using UnityEngine;
using LDG.MIDI;

public class MidiLoadResource : MonoBehaviour
{

public string midiResource;
public string audioResource;

public MidiSource midiSource;
public AudioSource audioSource;

// Use this for initialization
void Start()
{

MidiClip midiClip;
AudioClip audioClip;

midiSource = (midiSource) ? midiSource : gameObject.GetComponent<MidiSource>
();

audioSource = (audioSource) ? audioSource : gameOb-
ject.GetComponent<AudioSource>();

if (midiSource && audioSource)
{

midiClip = Resources.Load<MidiClip>(midiResource);
midiSource.clip = midiClip;

audioClip = Resources.Load<AudioClip>(audioResource);
audioSource.clip = audioClip;

audioSource.Play();
midiSource.Play();

}
}

}

Demos
See theMidiLoadResource scene in Demos included with Sound Reactor Pro.

Setup
1. Create a "Resources" folder inside Unity's "Assets" folder.
2. Create a path inside the "Resources" folder where you'd like your MIDI files to be.
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3. Create the above script in your project. If the Demowas unpackaged then this script already exists in your project.
4. Attach this script to a GameObject.
5. Provide the Resources path to your audio and midi files. If you don't have a corresponding audio file, then edit the script to
remove that dependency.
6. Drag an AudioSource andMidiSource from your scene into the property fields. If you don't have a corresponding audio
file, then edit the script to remove that dependency.

RESULT
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Record Peaks

SUMMARY
Peaks are used to scale frequencymagnitudes (Levels) to a range somewhere between 0 to 1.Without peaks,
the values are to arbitrary to trigger events reliably. For this reason,PeakProfiles can be created and shared
among any audio clip. SeeAudio Peaks for amore detailed explanation.

NOTE: If you're not looking to create a customPeakProfile, Sound Reactor includes several that will work with
any audio clip.

Creating a PeaksProfile
There aremultiple ways to create aPeaksProfile file. Here are themost commonways:
l Right click on an audio file and select: Create->SoundReactor->Peaks Profile
l Select: Create->Assets->SoundReactor->Peaks Profile
l Select: Tools->SoundReactor->Peaks Profile

Recording a PeaksProfile
1. First the profile must be made dirty. To make it dirty, either change one of its settings, or press the Reset button in the
inspector.

2. Attach it to a SpectrumSource.
3. Attach an AudioSource that is pointing to an AudioClip you’d like to record peaks for. To generate generic peaks, record the
peaks of a Sweep Sound.
4. Go into playmode and aRecord Peaks button will appear just under where the profile was attached to in the Spec-
trumSource. Press the button.

5. The peaks are done recording when the end of the AudioClip has been reached. Sound Reactor will confirm this by hiding
the record button and posting a message in the console.
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Color Driver

SUMMARY
This driver changes the color of:materials, particles, and vectors.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver

Color Mode
Themethod the color gradient is applied.
l Magnitude Sets the gradient color using the level's magnitude.
l Frequency Sets the gradient color using the level's frequency.

Stationary
Check this if a Segmented Levels shape was built with theSpectrumBuilder. This option only displayswhen
Color Mode is set to Magnitude.

Material Index
The index to amaterial for the attachedmesh.

Main Color
Themain color used to colorize the object. This changes the _Color property in the shader. If a _Color prop-
erty doesn’t exist, then the object will not be colorized.

Resting Color
This color is applied to segmented levels, and vector shapes that are anchored.
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Event Driver

SUMMARY
An easyway to animate properties in a class.
SeeEventDriverSetup for setup.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver

OnLevel
Takes an event handler that can processPropertyDriver values.
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Force Driver

SUMMARY
Applies a force to a GameObject that has a RigidBody attached to it.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver

Force Mode
How the force should be applied to the RigidBody.
l Force
l Impulse
l Velocity Change
l Acceleration

Force Type
What type of force to apply
l Force
l Torque
l Relative Force
l Relative Torque

Max Angular Velocity
Limits the angular velocity
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Midi Track Color Driver

SUMMARY
This driver changes the color of the notes associated with a particular MIDI track.

This feature is only available in Sound Reactor Pro.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver

Material Index
The index to amaterial for the attachedmesh.

Track Color
The colors used to color tracks. If there aremore tracks than colors, then colors will repeat. This changes the _
Color property in the shader. If a _Color property doesn’t exist, then the object will not be colorized.

Resting Color
This is the color used when theMIDI note velocity is close to zero.
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Particle Emitter Driver

SUMMARY
Emits specified number of particles.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver
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Position Driver

SUMMARY
Moves an object.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver
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Property Driver

SUMMARY
PropertyDrivers use themagnitude of a frequency stored in a Level to drive property values. This class ismeant
to be inherited from. All its properties are common and editable in the following scripts included with Sound
Reactor:PositionDriver,RotationDriver, ScaleDriver, ParticleEmitterDriver,ColorDriver, ForceDriver,
andEventDriver.

INSPECTOR

PROPERTIES

Level
The Level this driver uses to calculate the travel distance. If this is set to None, then it’ll try to find a Level at
runtime on theGameObject it’s attached to by looking up through the hierarchy.

Shared Driver
Travel, Max Level, Strength, andOn Beat are all overridden by this driver.

Travel
Defines the travel distance. If a level reaches 100% of itsmagnitude, and the travel is set to 10, then the travel dis-
tance will be 10.

Strength
Scales the level’smagnitude. This is useful to get values to reach their max travel distance sooner.

Clipping
Clips the level’smagnitude. A value of 1 will allow the level to reach 100% of itsmagnitude.

On Beat
Causes the Travel to reach 100% once per frame per beat. This is useful for physics and particle emitters.
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Rotation Driver

SUMMARY
Rotates object.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver
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Scale Driver

SUMMARY
Scales object.

INSPECTOR

PROPERTIES

Inherits From
PropertyDriver
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Level

SUMMARY
A Level points to a specific frequency inSpectrumSource, and its value is themagnitude of that frequency after
it has been normalized. The level itself is always falling at a certain rate, which is defined by theSpectrumFilter
it points to.

Some features are only available in Sound Reactor Pro.

INSPECTOR

PROPERTIES

Frequency Mode
Affects which frequency values should be displayed. Only available in Sound Reactor Pro.
l Audio is ~20Hz to ~20KHz
l MIDI is ~8.18Hz to ~12543.85KHz

Spectrum Filter
The filter to grab spectrum data from. If this is set to None, then it’ll try to find aSpectrumFilter at runtime on the
GameObject it’s attached to, then by looking up through the hierarchy for the first SpectrumFilter it finds.

Frequency (Hz)
The audio frequency that the level is tracking. You can either set the frequency directly in the edit field, or by left
clicking themouse inside the frequencywindow.When using theSpectrumBuilder, the frequency is auto-
matically set for each level created.

Fall Speed Source
The source to get the fall speed from.
l Spectrum Filter gets the fall speed from theSpectrum Filter→Fall Speed property
l Level gets the fall speed from this Level→Fall Speed property. The Fall Speed property shows when this option is set.
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Inheritable
Tells a childPropertyDriver if it can inherit a Level from another GameObject or not. The only exception is if the
PropertyDriver is attached to the same object as the Level.
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Spectrum Filter

SUMMARY
The SpectrumFilter is used tomodify the shape and scale of the spectrum. It also allows you to set the falling
speed and beat detection sensitivity of all levels parented to this filter.

INSPECTOR

PROPERTIES

Frequency Window
Red LineRepresents the frequency.
Green LineRepresents the normalized spectrum.
Blue LineRepresents the falling level.
Black LineWill change positionswhenever the threshold under Beat Sensitivity is reached.

Spectrum Source
TheSpectrumSource to filter. If this is set to None, then it’ll try to find aSpectrumSource at runtime on the
GameObject it’s attached to, then by looking up through the hierarchy for the first SpectrumSource it finds.

EQ
This gives you a little more control over how the spectrum is scaled. SeeEQ in this document for more details.

Interpolation
Sets whether values in between levels are interpolated as straight lines or curved.

Scale
Scales all incoming bandmagnitudes acquired from the attachedSpectrumSource.

Fall Speed
The speed at which the levels should fall. This is in normalized space, so setting the value to 1 will bring the level
from full height down to zero in 1 second. Setting this value to 2 would bring it all the way down in a half a second.
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Beat Trigger
Tells a beat to be triggered when the level: Ascends, Descends, or both.

Beat Sensitivity
Just like fall speed, this value is in normalized space. Setting this value to 0.75 would cause a beat to happen
when a level descends 75%. Setting the value to 0.5 would cause a beat to happen when the level descends
50%.
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Spectrum Source

SUMMARY
Converts aAudioSource orMidiSource to spectrum data, and then processes it for output toSpectrumFilter.

Some features are only available in Sound Reactor Pro.

INSPECTOR

PROPERTIES

Mode
Tells theSpectrumSourcewhat source to use. It can either be Audio or Midi.

Source
The source to pull spectrum data from. In Sound Reactor Pro this can either beMidi or Audio.

Channel
The audio channel to pull spectrum data from. If anAudioSource is attached and points to a validAudioClip, this
channel will be restricted to the highest supported channel for that clip.

Peaks Profile
A profile that stores peak data along with sample rate and amplitude type.

Bands
This sets how many bands the spectrumwill be divided into.

Normalize
Normalizes the attached levels to a range of 0 to 1.
l PeakNormalizes all levels based on the spectrum's peak.
l Peak BandNormalizes each level based on its own peak.
l RawNo scaling whatsoever, i.e. the unprocessed data straight from Unity’s GetSpectrumData function.
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Midi Clip

SUMMARY
AMidiClip is a ScriptableObject that has been generated from a .mid or .midi file. It containsmost of what is
stored in aMIDI file, and some additional things that make it easier for developers to use it in games.

This feature is only available in Sound Reactor Pro.

INSPECTOR

PROPERTIES

Preview Track
The track to preview in the preview window.

BUTTONS

Reload
Reloads theMIDI file that this asset was generated from.
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Midi Source

SUMMARY
Plays a MidiClip. The properties for this class are similar to Unity's AudioSource class.

This feature is only available in Sound Reactor Pro.

INSPECTOR

PROPERTIES

Clip
MidiClip to play.

Note Offset
Offsets theMIDI note being played. The new offset value is what gets passed toSpectrumSource and
OnMidiEvent.

Mute
Sound Reactor stops reacting, andOnMidiEvent stops being called, but time continues to pass.

Speed
Sets the playback speed. A value of 1 will play theMIDI sequence at normal speed.

Play On Awake
Automatically plays theMIDI sequence when the scene is loaded.

Loop
When set to true, theMIDI sequence will start over again at 0 when the end of the sequence is reached.
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On Midi Event
Takes a custom MidiEventHandler.
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Peaks Profile

SUMMARY
The PeaksProfile contains peaks used for normalizing spectrummagnitudes. SeeRecord Peaks for recording
custom peaks, otherwise the ones included with Sound Reactor work just fine.

INSPECTOR

PROPERTIES

Window
The quality of the spectrum data. The list is sorted so that low quality starts at the top, and high quality at the bot-
tom. The higher the quality the lower the performance, and vise versa.

Samples
The number of samples. The higher the number the higher the quality. The higher the quality the lower the per-
formance, and vise versa.

Amplitude
Sets whether to use decibel or linear magnitude.

BUTTONS

Reset
Button that marks the peak as dirty so it can be recorded to again.
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EQ

SUMMARY
Modifies the normalized magnitudes of the bands coming out of SpectrumSource.

INSPECTOR

PROPERTIES

Filter Band
All bands outside the specified range will be scaled to zero.

Slope
Scales the slope defined inMode.

Offset
Offsets all the levels.

Master
Scales the levels

Mode
Defines a shape for the levels.
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Spectrum Builder

SUMMARY
The SpectrumBuilder is the quickest and easiest way to build a visualizer. It makes it possible to create frequency
ranges in a variety of shapes, and even allows you to apply simple transforms to those frequencies to further cus-
tomize their arrangement along the shape.

Pianomode and associated properties are only available in Sound Reactor Pro. SeeMidiSetup for example
setup.

INSPECTOR

PROPERTIES

Mode

l Object creates an array of GameObjects from the levels specified in the Levels property.
l Vector creates it's ownGameObjects that become points in a curve.
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l Piano creates a piano from the specified piano keys. (only available in Pro)

Size
The Level is scaled by this size.

Levels
TheGameObjects containingPropertyDrivers. TheGameObjects will be created and repeated in the order that
they exist in the list. WhenMode is set to Object.

Share Driver
Tells the builder to attach thePropertyDrivers from the Level to the instanced Levels. WhenMode is set to
Object.

Color Driver
TheColorDriver to use for coloring the vector. WhenMode is set to Vector.

Travel
The distance the vertices shouldmove.WhenMode is set to Vector.

Anchored
Anchors the bottom or inside edge of the vector. WhenMode is set to Vector.

Anchored Diam.
Diameter of the inside edge of the vector. WhenMode is set to Vector and Anchored is checked.

Shape
The shape to arrange the Levels into.
l Line
l Circle
l Rectangle
l Segmented Levels

Spacing Mode
How the Levels should be spaced.
l Spaced evenly space levels based on their Level Size.
l Divided evenly divide the Layout Size into levels.

By Edge
Add space between level edges. Otherwise add space between level centers. Appears whenSpacingMode is
set toSpaced.

Fit Inside
Divide the layout so that the level edges are tangent to the Layout Size. Otherwise just divide the layout as if the
Level Sizewere zero. Appears whenSpacingMode is set toDivided.

Levels
The number of levels to build up the spectrumwith.
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Layout Size
The size of the layout. For Lines it's the length,Circles the diameter, and forRectangle/Segmented Levels the
number of rows and columns

Mode
This can be set to either Audio orMIDI. Audio frequency uses a sub range of ~20hz to ~20000kz, andMIDI uses
a sub range of 8.18hz to 12543.85hz.

Preset
Frequency range presets.

Lower (Hz)
Lower frequency of the range.

Upper (Hz)
Upper frequency of the range.

Clamp
Keeps the last level from becoming the first level.

Repeat
The number of times to repeat the frequency range along the shape. Only available whenClamp is unchecked.

Alternate
Tells the frequency to reverse every time it repeats.

Reverse
Causes the levels to be assigned frequencies starting with the highest frequency first.

Flip Level
Causes the levels to display upside down. Only workswithSegmented Levels.

Auto Build
Toggles auto build.
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Audio Peaks

SUMMARY
Audio peaks are an important part of visualizing spectrums, and evenmore important when you want things to
react to themagnitude of a frequency. This topic exists to help developers understand what peaks are and how
they are used tomake spectrum values useful.

Peaks
A peak is considered the highest possible magnitude of a frequency for a given sound. If we divide amagnitude
by it's peak, the result is a value that ranges from 0 all the way up to 1. This technique is called normalization, and
it is very useful when visualizing sounds, or writing events that react to sounds.

Raw Spectrum
Unity returns spectrum data at a very small scale, around 0.01, and those values are not very useful to us.
Moreover, the scale changes slightly depending on the sample rate, FFT window, andmagnitude type, i.e. dB vs.
Linear. What we need to do then is save the peaks of a sound so they can be used later to normalize the sound,
and Sound Reactor let's you do just that by allowing you to save peaks to a file called aPeaksProfile.

Peaks Profile
A PeaksProfile stores: sample rate, FFT window, magnitude type, peaks for 30 bands, and one peak for the
entire spectrum. There are two types of peaks profiles that can be recorded:
l Unique Peaks peaks used to normalize themagnitudes of one sound. Recording a peaks profile like this guarantees
that the highest magnitude of that sound will always reach a value of 1, but it means recording the peaks of every sound
you intend to play.

l Generic Peaks peaks used to normalize any sound. This method doesn't guarantee that the highest magnitude will
reach a value of 1, but it does means that you only need aminimum of one profile.

Generic Peaks
In order to record generic peaks you need a special sound file called a sweep tone. A sweep tone is a sound that
plays a tone from 20Hz all the way up to 20,000Hz at a constant dB, which is essentially creating a ceiling of
peaks. The result is a curve that looks like the following:

Sound Reactor already comeswith a few profiles that can be used, just look for:Decibel2048.peaks. However,
if you need to record your own, you can use the provided sound file, or generate one from awebsite that gen-
erates sweep tones, then follow this recording guide.

Bands
Last but not least. Sound Reactor doesn't record the peaks of every sample in the spectrum, it only records the
number of bands specified inSpectrumSource. Furthermore, when the peaks are saved to aPeaksProfile,
only 30 bands are saved. These peaks are automatically interpolated when saving, and when loading.
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MIDI

SUMMARY
MIDI stands forMusical Instrument Digital Interface. It's a standard communication protocol designed for
digital instruments such as: pianos, digital drums, and other various electronicmusical equipment. The standard
has been around since 1982, and has since been used by thousands of devices, even ones that don't play sound.

You can read up on theMIDI standard atMIDI Association.

This feature is only available in Sound Reactor Pro.

Sounds
There is actually no such thing as aMIDI sound. MIDI ismerely amessaging protocol, and it's job is to tell
MIDI software and deviceswhat to do. Themost notable one, of course, is to play sound, which is what it was ori-
ginally designed to do. Today, however, MIDI has been adapted to control many things, such as: lighting,
switches, movements, and so on.

Events
MIDI is an event drivenmessaging system. There aremany types of events, ranging from notes turning on and
off, to communicatingmetamessages that include tempo, cues, words/syllables, and even copyright notices. The
device listening to the events can do whatever it wants with them. It can play sounds, or do something else with
them. For example, Sound Reactor Pro uses the values tomodify properties such as: rotation, scale, position, or
any other property you tell it to.

Frequency
MIDI supports 128 notes, and since it was originally designed to be used with sound, they chose to assign fre-
quency values to those notes. The range they chose was: ~8hz to 12.5Khz..

INTEGRATION INTO SOUND REACTOR
Sound Reactor Pro handlesMIDI events andmessages in two ways:
l The reactor part of Sound Reactor Pro uses the note on/off events and their velocities to affect level magnitudes. In
other words, it works exactly the same as it's audio counterpart, except all the notes are individualized instead of being
a blendedmess of sound. This means you can drive properties to individual notes without bleed over from other notes.

l There is a new MidiSource class included with Sound Reactor Pro that lets you handleMIDI events andmessages
directly. For example, if you want to display lyrics, which is something that can be stored in aMIDI file, then they can be
handled and displayed to the screen using a customMidiEventHandler.

MIDI Support
Sound Reactor Pro can play back pre-processedMIDI files. It supports amajority of MIDI events andmessages,
but it doesNOT support playing soundfonts/synths or communicate with MIDI devices. See the following for what
is, and is not supported.
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Supported
l MIDI type 0 and 1 files.
l MIDI file playback
l Seeking to specific times
l Speedmultiplier

Unsupported
l Will not connect to MIDI devices
l Will not saveMIDI files
l Will not generateMIDI events
l Will not play soundfonts or synths.

Unsupported Events
l System Exclusive

Unsupported Meta Messages
l Device Name
l Channel Prefix
l MIDI Port
l SMPTE Offset
l Sequencer Specific

MIDI Files
Sound Reactor Pro doesn't openMIDI files directly, instead, they need to be converted to a .asset file (Script-
ableObject). Sound Reactor Pro adds extra info that MIDI doesn't include, like how long a note is held down for,
how many notes exist, and so on. SeeMidiFileSetup for how to create a .asset file.

NOTEWORTHY

Black MIDI
Since BlackMIDI is a thing, and it was used extensively to test theMIDI integration into Sound Reactor Pro, I feel
it should be covered here. BlackMIDIs areMIDI files that contain more notes than you can shake a stick at. In
other words, someone thought it was a good idea to see how many notes their computer could handle before
they could bring it down to its knees. Because of this, I relied heavily on these unique files to test every part of
Sound Reactor Pro. So a big thanks to all of you in the BlackMIDI community!!!
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